Configurations

 

1720 with multilink and NAT 20091021

 

 

Router#show run

Building configuration...

 

Current configuration : 2422 bytes

!

version 12.2

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

logging buffered 16384 debugging

aaa new-model

aaa authentication login default local-case

enable secret 5 $1$mhQ8$X5.jlb8oR9HIjkpZFd6x00

!

username bnsitech password 0 7300

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

ip dhcp excluded-address 192.168.42.21 192.168.42.31

ip dhcp excluded-address 192.168.42.32 192.168.42.63

ip dhcp excluded-address 192.168.42.64 192.168.42.95

ip dhcp excluded-address 192.168.42.96 192.168.42.99

ip dhcp excluded-address 192.168.42.150

ip dhcp excluded-address 192.168.42.151

ip dhcp excluded-address 192.168.42.152 192.168.42.159

ip dhcp excluded-address 192.168.42.160 192.168.42.191

ip dhcp excluded-address 192.168.42.192 192.168.42.255

ip dhcp excluded-address 192.168.42.1 192.168.42.20

!

ip dhcp pool hoot

   network 192.168.42.0 255.255.255.0

   default-router 192.168.42.1

   dns-server 12.5.48.2 12.5.48.4

   lease 0 12

!

no ip bootp server

!

!

!

!

interface Multilink3

 ip address 12.4.193.106 255.255.255.252

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip nat outside

 load-interval 30

 no cdp enable

 ppp multilink

 multilink-group 3

!

interface FastEthernet0

 ip address 192.168.42.1 255.255.255.0

 ip nat inside

 speed auto

 no cdp enable

!

interface Serial0

 ip address 12.4.193.150 255.255.255.252

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 encapsulation ppp

 load-interval 30

 no fair-queue

 no cdp enable

!

interface Serial1

 no ip address

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 encapsulation ppp

 load-interval 30

 no fair-queue

 no cdp enable

 ppp multilink

 multilink-group 3

!

ip nat inside source list 1 interface Multilink3 overload

ip classless

ip route 0.0.0.0 0.0.0.0 12.4.193.149

no ip http server

no ip pim bidir-enable

!

!

ip access-list extended wan

 deny   icmp any any redirect

 permit ip any any

access-list 1 permit 192.168.42.0 0.0.0.255

access-list 2020 permit icmp any any echo

access-list 2020 permit icmp any any echo-reply

access-list 2020 remark rate shaping on wan interfaces

no cdp run

!

line con 0

 exec-timeout 30 0

 transport preferred none

line aux 0

 transport preferred none

line vty 0 4

 exec-timeout 30 0

 transport preferred telnet

!

scheduler allocate 4000 1000

ntp authenticate

end

 

Router#